TLS 1.2 Problem bei einigen Hostern – z.B. Profihost

Home » CSProgramme » TLS 1.2 Problem bei einigen Hostern – z.B. Profihost

Seit ca. 12.6.2018 gibt es bei dem einen oder anderen Hoster das Problem die Showpare Version auszulesen. Dies liegt am neuen Verfahren mit der Version TLS 1.2.

Auch unsere Programme sind davon betroffen können aber mit einem kurzen Eingriff in die Registry wieder damit arbeiten.

Öffnen Sie den Windows Registry Editor wie folgt:
Win + R Taste dann geben Sie
Regedit
ein – alternativ links unten auf das Windows Symbol (START) dann
Regedit
eingeben


Navigieren Sie zu folgendem Pfad:

Für 64bit Betriebssysteme:
\HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\.NETFramework\v2.0.50727

und

\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\.NETFramework\v2.0.50727

 

 

Für 32bit Betriebssysteme:

Wenn es den obigen Pfad (WOW6432Node) nicht gibt, dann nutzen Sie ein 32bit Windows – dann lautet der Pfad:
\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\.NETFramework\v2.0.50727


Beachten Sie: Es heisst „Punkt NetFramework“ – da ist ein Punkt vorne dran!
Diesen Pfad MUSS es geben – er darf keinesfalls angelegt werden!
Erstellen Sie einen neuen DWORD-Wert (32bit) mit dem Wertname:
SystemDefaultTlsVersions
Und dem Inhalt
Hexadezimal 1

 

 

Beenden Sie den RegistryEditor (er speichert automatisch) und starten Sie dann SCSWFlex neu bzw. starten den PC komplett neu.
Der Eintrag zwingt das .Net Framework mit TLS1.2 zu arbeiten.
Dieser Trick funktioniert erst ab Windows 7 / Windows 2008R2 mit aktuellen Windows Updates. Windows Vista / XP werden nicht mehr funktionieren.

 

Weitere Infos finden Sie hier:

https://support.microsoft.com/de-de/help/3154520/support-for-tls-system-default-versions-included-in-the-net-framework

 

Achten Sie bei einem Windows 2016 Server darauf, dass da das 1803er Update installiert ist – das installiert sich möglicherweise nicht automatisch!

Posted on